Import-Module Security Warning

Sep 3, 2010 at 4:08 PM

Every time I run Import-Module SMLets it gives a security warning.  This is making scripting impossible.  I've noticed that other modules I use don't come up with this warning.  Is there any way the module can be changed to not come up with this warning?  Or perhaps a way of passing a run once in the import command or in a script that I don't know about?

Developer
Sep 4, 2010 at 6:41 AM

this is likely because you didn't unblock the zip file before you extracted the contents. Based on your security model, you may or may not have to do this (that is, depending on whether you've placed *.codeplex.com as a trusted internet site. There's two ways to do solve this problem. 

delete the module
unblock the zip archive 
unzip and install the archive

or

go to the module directory and unblock all the files therein

I can't be sure, that this is the problem, but it's the most likely.

jim