An object of class ManagementPackEnumeration with ID e1480348-20aa-942c-4896-44dba726424f was not found

Jan 18, 2011 at 4:50 PM

When I use the cmdlet, New-SCSMIncident, I am getting the following error "An object of class ManagementPackEnumeration wtih ID e1480348-20aa-942c-4896-44dba726424f "

Any ideas on what might be going on?

Thanks,

Andy

Jan 18, 2011 at 6:12 PM

By the way, we are using SP1, if that makes any difference.

Developer
Jan 18, 2011 at 6:17 PM

is it the official build of SP1 or a beta?

Jan 18, 2011 at 6:23 PM
Edited Jan 18, 2011 at 6:23 PM

the offical SP1

Jan 18, 2011 at 6:23 PM

sorry.. the official SP1.. not beta

Developer
Jan 18, 2011 at 6:43 PM

it looks like the enumeration doesn't exist - you can check this with get-scsmenumeration:

PS> Get-SCSMEnumeration -id e1480348-20aa-942c-4896-44dba726424f

This can change, based on whether you're using a official or beta build (this seems suspiciously like a beta build)

what's the output of new-mg?

Jan 18, 2011 at 6:56 PM

Get-SCSMEnumeration raises the same error..

Just out of curiosity, I tried using the cmdline tool called CreateIncident.exe which is using the SDK as well. I was able to successfully create an incident with it.

new-mg gives the following:

PS C:\users\superandys\Desktop\Debug> new-mg


ConnectorFramework     : Microsoft.EnterpriseManagement.ConnectorFramework.ConnectorFrameworkConfigurationManagement
EntityTypes            : Microsoft.EnterpriseManagement.EntityTypeManagement
EntityObjects          : Microsoft.EnterpriseManagement.InstancesManagement
Knowledge              : Microsoft.EnterpriseManagement.KnowledgeManagement
LanguagePacks          : Microsoft.EnterpriseManagement.LanguagePacksManagement
ManagementPacks        : Microsoft.EnterpriseManagement.ManagementPackManagement
Monitoring             : Microsoft.EnterpriseManagement.MonitoringConfigurationManagement
Overrides              : Microsoft.EnterpriseManagement.OverridesManagement
Presentation           : Microsoft.EnterpriseManagement.PresentationManagement
Reporting              : Microsoft.EnterpriseManagement.ReportingConfigurationManagement
Resources              : Microsoft.EnterpriseManagement.ResourceManagement
Security               : Microsoft.EnterpriseManagement.SecurityConfigurationManagement
Subscription           : Microsoft.EnterpriseManagement.Subscriptions.SubscriptionManagement
TaskConfiguration      : Microsoft.EnterpriseManagement.TaskConfigurationManagement
TaskRuntime            : Microsoft.EnterpriseManagement.TaskRuntimeManagement
Templates              : Microsoft.EnterpriseManagement.TemplatesManagement
TypeCache              : Microsoft.EnterpriseManagement.TypeCacheManagement
TypeDefinitions        : Microsoft.EnterpriseManagement.TypeDefinitionsManagement
DataWarehouse          : Microsoft.EnterpriseManagement.DataWarehouseManagement
Notifications          : Microsoft.EnterpriseManagement.NotificationManagement
ServiceLevelAgreements : Microsoft.EnterpriseManagement.ServiceLevelAgreementManagement
Deployment             : Microsoft.EnterpriseManagement.DeploymentManagement
UserSettings           : Microsoft.EnterpriseManagement.UserSettingsManagement
Name                   : ChangedNametoProtectTheInnocent
Id                     : 67b26a66-8407-7d93-7b13-3c806b75bc88
IsConnected            : True
CacheMode              : Configuration
AutoRefreshCache       : True
ProductId              : 02382-110-8022324-75611
ConnectionSettings     : Microsoft.EnterpriseManagement.EnterpriseManagementConnectionSettings
Version                : 7.0.6555.0
CurrentCountryCode     : ENU
OriginalCountryCode    : ENU
LifetimeManagers       : Microsoft.EnterpriseManagement.LifetimeManagerTypeRegistry
Features               : Microsoft.EnterpriseManagement.FeatureContainer

Developer
Jan 18, 2011 at 7:10 PM

consistent behavior is good (since the get-scsmenumeration and the incident cmdlet get the enumeration in the same way. We can determine whether it's a debug or retail build by inspecting the keytoken of the System.Library MP. What's the output of:

PS> Get-SCManagementPack -Name System.Library | format-list

Developer
Jan 18, 2011 at 7:29 PM

I'm not sure how CreateIncident.exe is implemented, so i don't know if it dynamically looks up the enumerations, i can tell you that the incident cmdlet has hardcoded a number of guids, so changes in debug/retail makes a difference.

 

 

Jan 18, 2011 at 7:57 PM

PS C:\users\superandys\Desktop\Debug> (Get-SCManagementPack -Name System.Library).keytoken
31bf3856ad364e35
PS C:\users\superandys\Desktop\Debug>

 

PS C:\users\superandys\Desktop\Debug> Get-SCManagementPack -Name System.Library | fl *


Name                  : System.Library
TimeCreated           : 6/1/2010 8:48:15 PM
LastModified          : 1/7/2011 2:09:57 AM
KeyToken              : 31bf3856ad364e35
Version               : 7.0.6555.0
Id                    : 01c8b236-3bce-9dba-6f1c-c119bcdc2972
VersionId             : e4a33190-4c57-d2ba-f811-4ad5a47f8187
References            : {}
Sealed                : True
ContentReadable       : True
FriendlyName          : System Library
DisplayName           : System Library
Description           : System Library: Root for all Management Packs.  Contains platform independent definitions.
DefaultLanguageCode   : ENU
ActiveLanguageCode    :
LockObject            : System.Object
SchemaVersion         : 1.1
OriginalSchemaVersion : 1.1
LifetimeManagers      : Microsoft.EnterpriseManagement.LifetimeManagerTypeRegistry
Features              : Microsoft.EnterpriseManagement.FeatureContainer

Developer
Jan 18, 2011 at 8:09 PM

that is strange - i'm not sure what's up. Let's see if the enumeration is there, but different from the way we ship it. what's the output of:

PS# get-scsmenumeration incidentclassificationenum | ft name,id,{$_.getmanagementpack()} -au

on my system it's:

PS# get-scsmenumeration incidentclassificationenum | ft name,id,{$_.getmanagementpack()} -au

Name                                              Id                                   $_.getmanagementpack()
----                                              --                                   ----------------------
IncidentClassificationEnum.Email                  27e10020-5cd7-146d-4329-16159477a8c4 [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum.Printing               bf261f09-5fad-eea4-24ce-1da889cef381 [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum.Other                  e1480348-20aa-942c-4896-44dba726424f [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum.Networking             b66fe115-9fe8-f1dc-b963-4ce3a82d671e [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum.Software               3929ce06-7494-d08e-5b89-564ed223c65a [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum.EnterpriseApplications 8a56f6df-dd32-864a-f4a7-625bcf36a594 [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum                        1f77f0ce-9e43-340f-1fd5-b11cc36c9cba [System.WorkItem.Incident.Library, 31bf3856ad364e35, 7.0.6555.0]
IncidentClassificationEnum.CIOverride             5cf234fc-b718-85dd-a8b3-bdaa92d8e89c [ServiceManager.IncidentManagement.Configuration]
IncidentClassificationEnum.Hardware               9c46171f-64a2-b33a-fbd3-d3ed9881cdf6 [ServiceManager.IncidentManagement.Configuration]

notice that the offending enum id is in the list. Could you have perhaps modified your list?